IPB

Welcome Guest ( Log In | Register )

3 Pages V   1 2 3 >  
Reply to this topicStart new topic
> Push based ActiveSync on Exchange2003 with MPX220.
nickpoore
post Dec 1 2004, 03:12 AM
Post #1


Advanced Member


Group: Members
Posts: 90
Joined: 1-June 04
From: LosAngeles
Member No.: 3,441
Phone: Palm Treo
Carrier: Verizon
PocketPC: HP iPAQ



From a VIRGIN MPX220.



Here are the instructions I created for syncing a brand new mobile phone with an Exchange 2003 server, and setting up auto-sync using a TMobile data service & SMS service.



I STRONGLY recommend that you subscribe to the unlimited GPRS internet plan ($20/mo) and the unlimited SMS ($10/mo) if you configure your phone like this.





Step ONE - Configuring Internet.

================================



Start -> 8.Settings -> 9.More -> 2.Data Connections.



Highlight "PDA Connect" under 'Internet Connection:'

Hit MENU -> 1.Edit Connections -> 4.GPRS Connections

Hit MENU -> 1.Add

Add the following settings to the new connection screen.

Description: TMobile GPRS

Connects to: The Internet

Access Point: internet2.voicestream.com

Username: <leave blank>

Password: <leave blank>

Primary DNS: <leave blank>

Secondary DNS: <leave blank>

IP address: <leave blank>

Hit DONE (returns you to GPRS Connections screen)

Hit DONE (returns you to Connections screen)

Hit DONE (returns you to Data Connections screen)



Under 'Internet Connection:' select "TMobile GPRS"

Hit DONE (returns you to Settings screen)

Hit DONE (returns you to main Start menu)



Hit 4.Internet Explorer

Hit MENU -> 6.Options

Highlight 'Connection' and hit SET (the blue button)

Go to "Select network:" and select "The Internet"

Hit DONE (returns you to the options screen)

Hit DONE (returns you to the Favorites screen).

Hit HOME (returns you to the Smartphone main screen.)





Step TWO - Confuring the mobile service on the server.

======================================================



Open up Exchange System Manager

Expand your organization

Expand global settings

Click on Mobile Services

Select ACTION (menu) then NEW then MOBILE CARRIER

Call the Carrier: TMobile

Make the SMTP domain: @tmomail.net

Click OK.

You should see a new mobile carrier icon.

Exit the Exchange System Manager.





Step THREE - Configuring Server ActiveSync on the MPX220.

=========================================================



Hit START -> 5.ActiveSync

Hit MENU -> Options -> 3.Server Settings -> 4.Connection

Enter the following settings:

username : <your network user ID>

password: <your network password>

domain: <your network domain>

server name: <The public FQDN of your mail server>

SSL: should be checked if you use it. You should.

Hit DONE (takes you back to Server Settings screen)



**NOTES.

Your username is your netork ID. This is often "nick" or "npoore". This is what you use



to login to your PC every day.

Your password is your network password.

Your domain is your network NetBios domain. This is usually "company" and not "company.com" or "company.local".

Your FQDN (fully qualified domain name" is usually something like "mail.company.com"



Hit 1.Inbox

Check the "Sync Inbox with a server" box.

Set "Include past:" to 2 weeks (or whatever you choose)

Set "Limit email size to" 5K (or whatever you choose)

Hit DONE (takes you back to Server Settings screen)



Hit 2.Calendar

Check the "Sync Calendar with a server" box.

Set "Include past:" to 6 months (or whatever you prefer)

Hit DONE (takes you back to Server Settings screen)



Hit 3.Contacts

Check the "Sync Contacts with a server" box.

Hit DONE (takes you back to Server Settings screen)



Hit DONE (takes you back to the Sync screen)

Hit DONE (take you back to the Main ActiveSync screen)



Hit SYNC

You should see:

Synchnorize with the server

- Connecting

- Looking for changes

- Synchronizing Calendar

- Synchronizing Contacts

- Synchronizing Messages

Ignore any prompts about keeping your phone up to date.



It may take two or three sync attempts to get your phone fully synced with the server.

Once you have a fully synced phone...



Hit MENU -> Options -> 1.Mobile Schedule.

Change the "Peak time sync:" to "When new items arrive".

Hit DONE (takes you back to the Sync screen)

Hit DONE (take you back to the Main ActiveSync screen)



SYNC the phone.



Once you have done this, then the phone will want to know what your mobile SMS address is.



Hit MENU -> Options -> 3.Server Settings -> 4.Connection

You will need to SCROLL DOWN through all the settings.

You will see some NEW options at the bottom of the list.

Address device using: SMTP Address

Service Provider name: TMobile (it pulled this from the server)

Device Phone number: wxxxyyyzzzz (it should auto-fill this for you)

Text Message address: wxxxyyyzzzz@tmomail.net



Hit DONE (takes you back to the Sync screen)

Hit DONE (take you back to the Main ActiveSync screen)



SYNC the phone.



Now, in my case, I have signed up to the TMobile website login, and changed my SMS email



address. (something like "nick@tmomail.net".)

Because of this, I put "nick@tmomail.net" into the "Text Message Address" field.



THis is all that it should take.



Note, that this is going to send you a LOT of SMS messages (which will be automatically deleted by the phone when they arrive.) I strongly advise that you sign up for the unlimited SMS plan, which is $10 per month.







Phew, that was a lot.

Let me know if anyone has questions.



-=Nick=-





Edit by Slacker: To save new users time - If you are a T-Mobile customer you will probably need to follow these instructions before this will work for you. Or if you followed these instructions and still don't get notifications then apply this fix. Additionally these instructions will work for any 2003 device, not just the MPx220.



QUOTE
You must apply the registry change found in KB 841995 FIRST! Then apply this hotfix.
Go to the top of the page
 
+Quote Post
lagrangeboy
post Dec 2 2004, 03:22 AM
Post #2


Newbie


Group: Members
Posts: 3
Joined: 1-December 04
Member No.: 5,999



Nick

If I do the same steps but just plug in the ATT info in place of the Tmobile stuff, it should work okay-right?
Thanks
Wayne
Go to the top of the page
 
+Quote Post
Slacker
post Dec 2 2004, 03:39 PM
Post #3


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



Boy I tell you, I must just be plain stupid. It absolutely does not work for me. I can manually sync over the air perfectly. I can set it to sync every xx minutes and it works perfectly. I know without a doubt my exchange server and phone are set up correctly.

So on top of being able to sync correctly, I added the T-Mobile option to MOBILE SERVICES on the server with @tmomail.net in the SMTP Domain box. That is the only change made to the server.

On the phone I made sure that the "T-Mobile" is selected as the SERVICE PROVIDER, that my phone number is in the DEVICE PHONE NUMBER box, and that my correct email is in the TEXT MESSAGE ADDRESS box (xxxxxx@tmomail.net). I use a name for the email VS a number because I changed my email on the T-Mobile site. I really thought that was my problem because I had been using my phone number @tmomail.net. But even putting the name I changed it to, still does nothing. So I tested sending an email to xxx@tmomail.net with the name. Nothing. I tested with the phone number @tmomail.net. Successfully received a SMS message. So I went back to ActiveSync on the phone and changed the text message address setting to the phone number @ tmomail.net WITHOUT a 1 in front of it. Didn't work. So I tried removing the 1 from the DEVICE PHONE NUMBER. Nothing.

I send email all day long to my exchange mailbox. The phone is set for when new items arrive. Nothing. It does nothing. Am I just plain stupid or what? I have a bald spot on the side of my head from pulling out the hair. Any suggestions?

How long after I send the message should the phone get it? Is there any indicator that a new mail has been received? Is there a log on the server I can look at to see if the SMS messages are going out? Any other troubleshooting ideas?


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post
jta
post Dec 2 2004, 05:36 PM
Post #4


Newbie


Group: Members
Posts: 6
Joined: 23-January 04
Member No.: 1,434



I had the same problem and it is an issue with the Exchange server sending messages with a blank From field that T-Mobile is blocking. Check out Microsoft Knowledge Base article 841995.
Go to the top of the page
 
+Quote Post
Slacker
post Dec 2 2004, 06:08 PM
Post #5


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



Do you have the hotfix file? Can you email it to me?


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post
nickpoore
post Dec 2 2004, 07:34 PM
Post #6


Advanced Member


Group: Members
Posts: 90
Joined: 1-June 04
From: LosAngeles
Member No.: 3,441
Phone: Palm Treo
Carrier: Verizon
PocketPC: HP iPAQ



Here is the master troubleshooting article.
http://support.microsoft.com/default.aspx?...kb;en-us;822176
Go to the top of the page
 
+Quote Post
nickpoore
post Dec 2 2004, 07:38 PM
Post #7


Advanced Member


Group: Members
Posts: 90
Joined: 1-June 04
From: LosAngeles
Member No.: 3,441
Phone: Palm Treo
Carrier: Verizon
PocketPC: HP iPAQ



Lastly, here's a great Microsoft Discussion on everything you ever wanted to know.
http://www.microsoft.com/technet/community...ge/exc0428.mspx
Go to the top of the page
 
+Quote Post
jta
post Dec 2 2004, 08:34 PM
Post #8


Newbie


Group: Members
Posts: 6
Joined: 23-January 04
Member No.: 1,434



Slacker,

Unfortunately, I do not have the hotfix file. I never got around to fixing this issue.
Go to the top of the page
 
+Quote Post
Slacker
post Dec 2 2004, 10:58 PM
Post #9


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



Well I paid the ripoff $99 and am waiting on the file. I will post it here when the crooks send it to me.


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post
D-Pop
post Dec 3 2004, 12:16 AM
Post #10


Member


Group: Members
Posts: 47
Joined: 24-June 04
Member No.: 3,809



We had a similar issue... my Cingular MPX220 was working fine but a couple of TMobile IPAQ 6315s were not working with the Auto-Up-To-Date function. The hotfix worked fine. I called Microsoft and they sent me the file free of charge!
Go to the top of the page
 
+Quote Post
Slacker
post Dec 3 2004, 01:19 AM
Post #11


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



Want to share that file? Email is in my sig below if you do.


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post
Slacker
post Dec 3 2004, 10:09 AM
Post #12


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



Here is the hotfix. Cost me $99. Thanks for nothing Microsoft.



Exchange2003-KB841995-x86-enu.exe



You must apply the registry change found in KB 841995 FIRST! Then apply this hotfix.



I have applied the fix and will see if my mail magically starts working today.


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post
Slacker
post Dec 3 2004, 12:21 PM
Post #13


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



WOOHOO!!!! IT WORKS!

For MONTHS I have been banging my head on the table with this issue. The hotfix installs in about 2 minutes and it just all started working. The messages take 3-4 minutes to show up on the phone.

However, Nick indicated that SMS messages would be an issue. I am not convinced of that. Does T-Mobile charge for INCOMING messages?


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post
GrYph0n
post Dec 3 2004, 08:14 PM
Post #14


Site Administrator
Group Icon

Group: Super Moderator
Posts: 3,190
Joined: 8-January 04
From: Southern California
Member No.: 1,097
Phone: Other
Carrier: AT&T Wireless/Cingular
PocketPC: HTC
MP3 Player: Creative
PMC: Creative Zen
Google Talk ID: eric.d.jones (at) gmail.com



Yes T-Mobile charges 5cents incomming and 5cents outgoing. I recommend getting an SMS bucket. I think it is like $2.99 for 300 and $7.99 for 1000, but don't quote me on that. I am positive that they do charge for incoming SMS though.


--------------------
Eric Jones
Editor / Moderator
Mobile Gadget News
Staff Sergeant
United States Marine Corps, Infantry
Currently using an iPhone
My Gadget History : AT&T Tilt,
Cingular 3125, i-Mate Smartflip, G-Sat BT359W GPS, Parrot Rhythm n'Blue BT Car Stereo, Logitech Mobile Traveller, & ThinkOutside BT Keyboard
Go to the top of the page
 
+Quote Post
nickpoore
post Dec 7 2004, 05:10 PM
Post #15


Advanced Member


Group: Members
Posts: 90
Joined: 1-June 04
From: LosAngeles
Member No.: 3,441
Phone: Palm Treo
Carrier: Verizon
PocketPC: HP iPAQ



QUOTE
WOOHOO!!!! IT WORKS!


Congratulations Slacker...

It's a shame you had to pay for the hotfix. I have never had to pay for a hotfix before. Normally I just call up and refer to the KB article and say that it said that I had to call for the hotfix, and I get to speak with a technician who verifies everything and supplies it for free.

You might like to call MS back and ask for a refund, asking why you have to pay for a software fix for software you have already purchased.

However, bottom line here is that I'm glad that you got it working. biggrin.gif
Go to the top of the page
 
+Quote Post
Slacker
post Dec 7 2004, 05:29 PM
Post #16


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



Actually they did issue a refund. So in the long run I got it free. But their support system sucks. Why not just let us DL the file?


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post
ssommer
post Dec 14 2004, 05:57 PM
Post #17


Newbie


Group: Members
Posts: 9
Joined: 25-November 04
Member No.: 5,898



Well, after reading this forum (thanks for the HF Slacker) I installed SP1 for Exchange and the HF. I got the push sync to work and thought I was done. However, after it successfully syncs once on the next sync it gets a HTTP_400 error. If I make changes under ActiveSync's connection settings and save them, then change them back and let it sync up from scratch it works for 1 time again. The full error reads:

Your account does not have permission to sync with your current settings. Contact your Microsoft Exchange administrator.

An error occurred, and the scheduled synchronization had to be disabled. To start synchronizing on a schedule again, use the Mobile Schedule tab in ActiveSync Options.

Error code: HTTP_400

I found a couple posts via a Google search of people having this issue, but no solution. I did try uninstalling the HF, reinstalling SP1, and then reinstalling the HF. Also have experimented with all sorts of permissions on the Exchange virtual directories in IIS. I've tried all sorts of combinations to submit the credentials like using domainusername and username@domain.com. My new MPx220 will be here tomorrow with the new firmware and I hope that takes care of it. I doubt it though, seems like a server side issue.
Go to the top of the page
 
+Quote Post
Slacker
post Dec 15 2004, 12:03 PM
Post #18


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



Your error suggests you are NOT using SSL. Let me just go on record and say that anyone who does not use SSL for Exchange is just BEGGING to be pwned. With that said, go to CA Cert and get a free server cert, or make your own with Win2k3. Then use the Microsoft Disable Cert Checking program to turn off the certificate verification on the phone.

With Activesync you should always make sure that you can first sync when connected to a computer. If you can't, over the air will never work. So go back to that and eliminate the GPRS. Next, give us all of your settings for activesync. Tell us exactly what you are using (minus login and password info of course). If you don't feel comfortable advertising your FQDN of your Exchange server, PM it to me or something. But unless we can see your settings, not much we can do to help.

FWIW, the error you gave is not on this site which seems to be the authority on ActiveSync.


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post
ssommer
post Dec 16 2004, 03:06 AM
Post #19


Newbie


Group: Members
Posts: 9
Joined: 25-November 04
Member No.: 5,898



QUOTE
Your error suggests you are NOT using SSL. Let me just go on record and say that anyone who does not use SSL for Exchange is just BEGGING to be pwned. With that said, go to CA Cert and get a free server cert, or make your own with Win2k3. Then use the Microsoft Disable Cert Checking program to turn off the certificate verification on the phone.

With Activesync you should always make sure that you can first sync when connected to a computer. If you can't, over the air will never work. So go back to that and eliminate the GPRS. Next, give us all of your settings for activesync. Tell us exactly what you are using (minus login and password info of course). If you don't feel comfortable advertising your FQDN of your Exchange server, PM it to me or something. But unless we can see your settings, not much we can do to help.

FWIW, the error you gave is not on this site which seems to be the authority on ActiveSync.
Thanks for the tip on SSL, I wasn't using it before because I always came through VPN before I got this phone. So I went to CA Cert, got a cert and installed it. Then I downlaoded and ran the disable cert check program. Next I reset the permissions on all of the virtual directories to their default settings, exactly the settings from this site:
http://www.msexchange.org/tutorials/Securi...s-Chapter5.html
I'm still getting the same HTTP_400 error. I get it both over the air and directly connected to ActiveSync on my PC. It works the first time both over the air and through a USB connection. It also works once when I change between connection methods, reset the phone, or restart Exchange and IIS on the server. It also works randomly through manual sync.
My ActiveSync settings on the phone are as follows:
User Name:
Just my username, no spaces, no / or , and no @. Just plain username.
Password:
My password.
Domain:
mydomain.com
Save password
Server Name:
mail.mydomain.com
Checked off This server uses an SSL connection.
Address device using:
SMTP Address
Service Provider Name
Cingular
Device Phone Number
xxxxxxxxxx
Text Message Address
xxxxxxxxxx@mobile.mycingular.com

I'll send you more specific info via a pm Slacker.
Thanks!
Go to the top of the page
 
+Quote Post
Slacker
post Dec 17 2004, 11:27 PM
Post #20


Site Administrator
Group Icon

Group: Admin
Posts: 2,659
Joined: 2-February 04
From: Alexandria, VA
Member No.: 1,609
Phone: HTC Wizard
Carrier: T-Mobile
PocketPC: HTC



Check your PM response.


--------------------
Jim Cleek (Slacker)
Editor / Administrator
Mobile Gadget News

My Gadgets
iPhone 3GS
HTC TyTN II
HTC Wizard
HTC Touch Dual
Motorola MPX220
Motorola MPX200
HP Ipaq 5550
Go to the top of the page
 
+Quote Post

3 Pages V   1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

RSS Lo-Fi Version Time is now: 23rd April 2017 - 05:28 AM